What are the minimum hardware/software requirements for the course?

The games we produce in Unity are not highly graphics intensive so you should be able to get by with the minimum requirements for Unity:

OS: Windows 7 SP1+, 8, 10; Mac OS X 10.8+.

Windows XP & Vista are not supported; and server versions of Windows & OS X are not tested.

GPU: Graphics card with DX9 (shader model 2.0) capabilities. Anything made since 2004 should work.

If you are planning to make a game which is more intensive then Unity will be able to support anything up to the most spec'ed out hardware. It will be possible to tailor your games for your hardware capabilities.

Feedback and Knowledge Base